Cross-Site Scripting (XSS) on Omada Controllers
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) vulnerability was identified in a parameter in Omada Controllers due to improper input sanitization. Exploitation requires advanced conditions, such as network positioning or emulating a trusted entity, and user interaction by an authenticated administrator. If successful, an attacker could execute arbitrary JavaScript in the administrator’s browser, potentially exposing sensitive information and compromising confidentiality.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| TP-Link | Omada Software Controller | before 6.0.0.24 | 6.0.0.24 | Patch available | CNA |
| TP-Link | Omada OC200, OC220, OC300, OC400 | before 6.0.0.34 | 6.0.0.34 | Patch available | CNA |
| TP-Link | Omada cloud controller | before 6.0.0.100 | 6.0.0.100 | Patch available | CNA |
- Omada Software Controller VendorTP-Link Affected before 6.0.0.24 Fixed in 6.0.0.24 Patch available CNA
- Omada OC200, OC220, OC300, OC400 VendorTP-Link Affected before 6.0.0.34 Fixed in 6.0.0.34 Patch available CNA
- Omada cloud controller VendorTP-Link Affected before 6.0.0.100 Fixed in 6.0.0.100 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tp-link:omada_controller:*:*:*:*:-:*:*:* | before 6.0.0.24 | Vulnerable | TP-Link |
| cpe:2.3:a:tp-link:omada_controller:*:*:*:*:cloud:*:*:* | before 6.0.0.100 | Vulnerable | TP-Link |
| cpe:2.3:o:tp-link:oc200_firmware:*:*:*:*:*:*:*:* | before 1.37.9 | Vulnerable | TP-Link |
| cpe:2.3:h:tp-link:oc200:1:*:*:*:*:*:*:* | 1 | Running on | TP-Link |
| cpe:2.3:o:tp-link:oc220_firmware:*:*:*:*:*:*:*:* | before 1.2.9 | Vulnerable | TP-Link |
| cpe:2.3:h:tp-link:oc220:1:*:*:*:*:*:*:* | 1 | Running on | TP-Link |
| cpe:2.3:o:tp-link:oc300_firmware:*:*:*:*:*:*:*:* | before 1.31.9 | Vulnerable | TP-Link |
| cpe:2.3:h:tp-link:oc300:1.6:*:*:*:*:*:*:* | 1.6 | Running on | TP-Link |
| cpe:2.3:o:tp-link:oc400_firmware:*:*:*:*:*:*:*:* | before 1.9.9 | Vulnerable | TP-Link |
| cpe:2.3:h:tp-link:oc400:1.6:*:*:*:*:*:*:* | 1.6 | Running on | TP-Link |
- cpe:2.3:a:tp-link:omada_controller:*:*:*:*:-:*:*:* Versions before 6.0.0.24 Vulnerable ·TP-Link
- cpe:2.3:a:tp-link:omada_controller:*:*:*:*:cloud:*:*:* Versions before 6.0.0.100 Vulnerable ·TP-Link
- cpe:2.3:o:tp-link:oc200_firmware:*:*:*:*:*:*:*:* Versions before 1.37.9 Vulnerable ·TP-Link
- cpe:2.3:h:tp-link:oc200:1:*:*:*:*:*:*:* Versions 1 Running on ·TP-Link
- cpe:2.3:o:tp-link:oc220_firmware:*:*:*:*:*:*:*:* Versions before 1.2.9 Vulnerable ·TP-Link
- cpe:2.3:h:tp-link:oc220:1:*:*:*:*:*:*:* Versions 1 Running on ·TP-Link
- cpe:2.3:o:tp-link:oc300_firmware:*:*:*:*:*:*:*:* Versions before 1.31.9 Vulnerable ·TP-Link
- cpe:2.3:h:tp-link:oc300:1.6:*:*:*:*:*:*:* Versions 1.6 Running on ·TP-Link
- cpe:2.3:o:tp-link:oc400_firmware:*:*:*:*:*:*:*:* Versions before 1.9.9 Vulnerable ·TP-Link
- cpe:2.3:h:tp-link:oc400:1.6:*:*:*:*:*:*:* Versions 1.6 Running on ·TP-Link
Remediation
- Fix · CNA Omada Software Controller (TP-Link Systems Inc.) Fixed in 6.0.0.24
- Fix · CNA Omada OC200, OC220, OC300, OC400 (TP-Link Systems Inc.) Fixed in 6.0.0.34
- Fix · CNA Omada cloud controller (TP-Link Systems Inc.) Fixed in 6.0.0.100
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
TP-Link Systems Omada Cloud Controller, Omada Software Controller — support.omadanetworks.com/us/document/114950
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2025-08515 Authentication Weakness on Omada Controllers, Gateways and Access PointsPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9289
- 2026-10-03 Alias added: GHSA-fh4h-xf29-c53g
References
More TP-Link Oc200 Firmware vulnerabilities
- TI-2025-08515 Authentication Weakness on Omada Controllers, Gateways and Access Points CVSS 4.0MEDIUM 6.0
Sources
- CVE-2025-9289 · CVE Program
- CVE-2025-9289 · NVD
- FIRST EPSS
- GHSA-fh4h-xf29-c53g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences