appneta tcpreplay parse_args.c tcpedit_post_args null pointer dereference
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.
Summary
A vulnerability was detected in appneta tcpreplay up to 4.5.1. Impacted is the function tcpedit_post_args of the file /src/tcpedit/parse_args.c. The manipulation results in null pointer dereference. The attack is only possible with local access. The exploit is now public and may be used. Upgrading to version 4.5.2-beta2 is recommended to address this issue. Upgrading the affected component is advised. The vendor explains, that he was "[a]ble to reproduce in 6fcbf03 but not in 4.5.2-beta2".
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA tcpreplay (appneta) Fixed in 4.5.2-beta2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9384
- 2026-10-03 Alias added: GHSA-gc8m-9gpv-3rpr
References
More Broadcom Tcpreplay vulnerabilities
- TI-2024-15099 tcpreplay v4.4.4 was discovered to contain an infinite loop via the tcprewrite function at get.c. CVSS 3.1HIGH 7.5
- TI-2025-32293 Within tcpreplay's tcprewrite, a double free vulnerability has been identified in the… CVSS 3.1HIGH 7.8
- TI-2023-12413 An issue found in TCPreplay tcprewrite v.4.4.3 allows a remote attacker to cause a denial… CVSS 3.1HIGH 7.5
- TI-2024-02831 appneta tcpreplay get.c get_layer4_v6 heap-based overflow CVSS 3.1HIGH 7.8
- TI-2025-32292 A heap-buffer-overflow vulnerability exists in the tcpliveplay utility of the… CVSS 3.1HIGH 7.5
- TI-2023-12419 An issue found in TCPprep v.4.4.3 allows a remote attacker to cause a denial of service… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-9384 · CVE Program
- CVE-2025-9384 · NVD
- FIRST EPSS
- GHSA-gc8m-9gpv-3rpr · GitHub Advisory Database · CC BY 4.0
- CVE-2025-9384 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences