Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 that could allow an attacker to inject malicious content that may lead to account takeover.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 14.10 to before 18.2.7; 18.3 to before 18.3.3; 18.4 to before 18.4.1 | 18.2.7, 18.3.3, 18.4.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 14.10 to before 18.2.7; 18.3 to before 18.3.3; 18.4 to before 18.4.1 Fixed in 18.2.7, 18.3.3, 18.4.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.10.0 to before 18.2.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.10.0 to before 18.2.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.3.0 to before 18.3.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.3.0 to before 18.3.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.4.0:*:*:*:community:*:*:* | 18.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.4.0:*:*:*:enterprise:*:*:* | 18.4.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.10.0 to before 18.2.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.10.0 to before 18.2.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.3.0 to before 18.3.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.3.0 to before 18.3.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.4.0:*:*:*:community:*:*:* Versions 18.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.4.0:*:*:*:enterprise:*:*:* Versions 18.4.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.2.7, 18.3.3, 18.4.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.2.7, 18.3.3, 18.4.1
9 records Highest priority Priority MEDIUM 3 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2025-09947 Allocation of Resources Without Limits or Throttling in GitLabPriority MEDIUM 40
- TI-2025-07018 Privilege Defined With Unsafe Actions in GitLabPriority MEDIUM 40
- TI-2025-09956 Missing Authorization in GitLabPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9642
- 2026-10-03 Alias added: GHSA-2g5p-9p7q-76jj
References
Exploit 1
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-9642 · CVE Program
- CVE-2025-9642 · NVD
- FIRST EPSS
- GHSA-2g5p-9p7q-76jj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences