A local privilege escalation vulnerability in Nokia SR Linux
Priority LOW 27CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-269.
Summary
Nokia SR Linux is vulnerable to a local privilege escalation vulnerability. Successful exploitation of this vulnerability may allow an authenticated user to execute arbitrary commands with superuser privilege.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0011 1st percentileScored 2026-11-07
Fix Fixed Nokia SR Linux (Nokia): 23.10.8, 24.10.6, 25.7.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Nokia SR Linux (Nokia) Fixed in 23.10.8, 24.10.6, 25.7.2
- Fix · CNA Nokia SR Linux (Nokia) Fixed in 23.10.8, 24.10.6, 25.7.2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9912
- 2026-10-03 Alias added: GHSA-qpm5-pwpp-hh9x
References
More Nokia vulnerabilities
- TI-2022-12519 /SecurityManagement/html/createuser.jsf in Nokia NetAct 22 allows CSRF. CVSS 3.1HIGH 8.8
- TI-2022-11485 An issue was discovered in Nokia NetAct 22 through the Administration of Measurements… CVSS 3.1HIGH 8.8
- TI-2022-11484 An issue was discovered in Nokia NetAct 22. CVSS 3.1HIGH 8.8
- TI-2023-21971 Nokia Service Router Operating System (SR OS) 22.10 and SR Linux, when error-handling… CVSS 3.1HIGH 7.5
- TI-2022-16599 Nokia Fastmile 3tg00118abad52 devices shipped by Optus are shipped with a default… CVSS 3.1HIGH 8.4
- TI-2022-22690 Nokia Broadcast Message Center (BMC) before 13.1 allows an unauthenticated remote… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-9912 · CVE Program
- CVE-2025-9912 · NVD
- FIRST EPSS
- GHSA-qpm5-pwpp-hh9x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences