SpyShelter IOCTL SpyShelter.sys denial of service
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.
Summary
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available to the public and could be exploited. Upgrading to version 15.4.0.1028 is able to address this issue. It is advisable to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | SpyShelter | 15.4.0.1015 | 15.4.0.1028 | Patch available | CNA |
- SpyShelter Vendor— Affected 15.4.0.1015 Fixed in 15.4.0.1028 Patch available CNA
Remediation
- Fix · CNA SpyShelter Fixed in 15.4.0.1028
Timeline
- 2026-10-02 Threatist record created from CVE-2025-10475
- 2026-10-03 Alias added: GHSA-2c6v-v6m8-9jvh
References
Sources
- CVE-2025-10475 · CVE Program
- CVE-2025-10475 · NVD
- FIRST EPSS
- GHSA-2c6v-v6m8-9jvh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences