Cross-Site Scripting Vulnerability in QWC2 Registration GUI
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability in QGIS QWC2 Registration GUI <=v2025.03.31 allows an authorized attacker to plant arbitrary JavaScript code in the page
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00424 36th percentileScored 2026-11-07
Fix Fixed qwc-registration-gui (qwc-services): 2025.09.30
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| qwc-services | qwc-registration-gui | up to v2025.03.31 | 2025.09.30 | Patch available | CNA |
- qwc-registration-gui Vendorqwc-services Affected up to v2025.03.31 Fixed in 2025.09.30 Patch available CNA
Remediation
- Fix · CNA qwc-registration-gui (qwc-services) Fixed in 2025.09.30
Timeline
- 2026-10-02 Threatist record created from CVE-2025-11184
- 2026-10-03 Alias added: GHSA-qhh9-jphj-p4xw
References
Sources
- CVE-2025-11184 · CVE Program
- CVE-2025-11184 · NVD
- FIRST EPSS
- GHSA-qhh9-jphj-p4xw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences