Read the docs
TI-2025-10286 Aliases CVE-2025-11232GHSA-wcxf-jmjh-x27q

Invalid characters cause assert

Priority LOW 39CWE-823Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.

Summary

To trigger the issue, three configuration parameters must have specific settings: "hostname-char-set" must be left at the default setting, which is "[^A-Za-z0-9.-]"; "hostname-char-replacement" must be empty (the default); and "ddns-qualifying-suffix" must *NOT* be empty (the default is empty). DDNS updates do not need to be enabled for this issue to manifest. A client that sends certain option content would then cause kea-dhcp4 to exit unexpectedly. This issue affects Kea versions 3.0.1 through 3.0.1 and 3.1.1 through 3.1.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00424 36th percentileScored 2026-11-07
Fix Fixed Kea (ISC): 2.6.0, 2.7.0, 3.0.0 +1Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCKea3.0.1 – 3.0.1; 3.1.1 – 3.1.22.6.0, 2.7.0, 3.0.0, 3.1.0Patch availableCNA
  • Kea VendorISC Affected 3.0.1 – 3.0.1; 3.1.1 – 3.1.2 Fixed in 2.6.0, 2.7.0, 3.0.0, 3.1.0 Patch available CNA

Remediation

  • Fix · CNA Kea (ISC) Fixed in 2.6.0, 2.7.0, 3.0.0, 3.1.0

Red Hat 1 advisory

  • RHSA-2025:21038 Released 2025-11-11 · Red Hat rating Important
    kea security update
    • Red Hat Enterprise Linux AppStream (v. 10) kea-doc-3.0.1-2.el10_1, kea-hooks-3.0.1-2.el10_1
    • Red Hat Enterprise Linux BaseOS (v. 10) kea-3.0.1-2.el10_1, kea-libs-3.0.1-2.el10_1
    • Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) kea-keama-3.0.1-2.el10_1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 10)Fixed RHSA-2025:21038
Red Hat Enterprise Linux BaseOS (v. 10)Fixed RHSA-2025:21038
Red Hat Enterprise Linux CodeReady Linux Builder (v. 10)Fixed RHSA-2025:21038

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-11232
  2. 2026-10-03 Alias added: GHSA-wcxf-jmjh-x27q

References

Advisory 1

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
See all 285 →

Sources