Read the docs
TI-2025-10310 Aliases CVE-2025-11261GHSA-jrq3-c447-h584

Stored i18n XSS exposed by security patch for T402077

Priority LOW 2CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Language/mediawiki.Language.Js. This issue affects MediaWiki: from * before 1.39.15, 1.43.5, 1.44.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00259 17th percentileScored 2026-11-07
Fix Fixed MediaWiki (Wikimedia Foundation): 1.39.15, 1.43.5, 1.44.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediaWikibefore 1.39.15, 1.43.5, 1.44.21.39.15, 1.43.5, 1.44.2Patch availableCNA
  • MediaWiki VendorWikimedia Foundation Affected before 1.39.15, 1.43.5, 1.44.2 Fixed in 1.39.15, 1.43.5, 1.44.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*before 1.39.15; 1.43.0 to before 1.43.5; 1.44.0 to before 1.44.2Vulnerablemediawiki
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.39.15; 1.43.0 to before 1.43.5; 1.44.0 to before 1.44.2 Vulnerable ·mediawiki

Remediation

  • Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.39.15, 1.43.5, 1.44.2

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-11261
  2. 2026-10-03 Alias added: GHSA-jrq3-c447-h584

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources