Server-Side Request Forgery (SSRF) in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.0 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions, could have allowed an authenticated user to perform server-side request forgery against internal services by bypassing protections in the Git repository import functionality.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 18.0 to before 18.6.6; 18.7 to before 18.7.4; 18.8 to before 18.8.4 | 18.6.6, 18.7.4, 18.8.4 | Patch available | CNA |
- GitLab VendorGitLab Affected 18.0 to before 18.6.6; 18.7 to before 18.7.4; 18.8 to before 18.8.4 Fixed in 18.6.6, 18.7.4, 18.8.4 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.0.0 to before 18.6.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.0.0 to before 18.6.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.7.0 to before 18.7.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.7.0 to before 18.7.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.8.0 to before 18.8.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.8.0 to before 18.8.4 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.0.0 to before 18.6.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.0.0 to before 18.6.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.7.0 to before 18.7.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.7.0 to before 18.7.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.8.0 to before 18.8.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.8.0 to before 18.8.4 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.6.6, 18.7.4, 18.8.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.6.6, 18.7.4, 18.8.4
13 records Highest priority Priority HIGH 1 HIGH, 4 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2026-01155 Allocation of Resources Without Limits or Throttling in GitLabPriority HIGH 66
- TI-2026-01086 Allocation of Resources Without Limits or Throttling in GitLabPriority MEDIUM 62
- TI-2026-00998 Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in GitLabPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12073
- 2026-10-03 Alias added: GHSA-hfx3-365h-vfrv
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-12073 · CVE Program
- CVE-2025-12073 · NVD
- FIRST EPSS
- GHSA-hfx3-365h-vfrv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences