Read the docs
TI-2025-11108 Aliases CVE-2025-12113GHSA-hxc8-52qr-2m6j

Missing authorization in WebToffee Alt Text Generator AI – Auto Generate & Bulk Update…

Priority LOW 19CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The Alt Text Generator AI – Auto Generate & Bulk Update Alt Texts For Images plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the atgai_delete_api_key() function in all versions up to, and including, 1.8.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete the API key connected to the site.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00195 9th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WebToffeeAlt Text Generator AI – Auto Generate & Bulk Update Alt Texts For Imagesup to 1.8.3—No fix listedCNA
  • Alt Text Generator AI – Auto Generate & Bulk Update Alt Texts For Images VendorWebToffee Affected up to 1.8.3 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-12113
  2. 2026-10-03 Alias added: GHSA-hxc8-52qr-2m6j

References

  • TI-2024-07682 GDPR Cookie Consent <= 2.6.0 - Bulk Delete via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2024-07785 GDPR Cookie Consent <= 2.6.0 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-20216 WordPress Export and Import Users and Customers plugin <= 2.5.2 - Path Traversal vulnerability CVSS 3.1MEDIUM 4.3
  • TI-2024-00649 Stripe Payment Plugin for WooCommerce <= 3.7.9 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2023-02962 Stripe Payment Plugin for WooCommerce <= 3.7.7 - Authentication Bypass CVSS 3.1CRITICAL 9.8
  • TI-2022-23148 WordPress Product Reviews Import Export for WooCommerce Plugin <= 1.4.8 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
See all 68 →

Sources