Remote Code Execution in Looker due to Improperly Validated Directory Deletion
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Active
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
An attacker with a Looker Developer role could manipulate a LookML project to exploit a race condition during Git directory deletion, leading to arbitrary command execution on the Looker instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.103+ * 24.18.195+ * 25.0.72+ * 25.6.60+ * 25.8.42+ * 25.10.22+
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Looker | before 24.12.103; before 24.18.195; before 25.0.72; before 25.6.60; before 25.8.42; before 25.10.22 | 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22 | Patch available | CNA | |
| Looker | before 24.12.103; before 24.18.195; before 25.0.72; before 25.6.60; before 25.8.42; before 25.10.22 | 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22 | Patch available | CNA |
- Looker VendorGoogle Affected before 24.12.103; before 24.18.195; before 25.0.72; before 25.6.60; before 25.8.42; before 25.10.22 Fixed in 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22 Patch available CNA
- Looker VendorGoogle Affected before 24.12.103; before 24.18.195; before 25.0.72; before 25.6.60; before 25.8.42; before 25.10.22 Fixed in 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22 Patch available CNA
Remediation
- Fix · CNA Looker (Google Cloud) Fixed in 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22
- Fix · CNA Looker (Google Cloud) Fixed in 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, 25.10.22
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12472
- 2026-10-03 Alias added: GHSA-2h5q-w7wv-63r9
References
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2025-12472 · CVE Program
- CVE-2025-12472 · NVD
- FIRST EPSS
- GHSA-2h5q-w7wv-63r9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences