Code injection in silentmatt expr-eval
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The expr-eval library is a JavaScript expression parser and evaluator designed to safely evaluate mathematical expressions with user-defined variables. However, due to insufficient input validation, an attacker can pass a crafted context object or use MEMBER of the context object into the evaluate() function and trigger arbitrary code execution.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| silentmatt | expr-eval | up to 2.0.2 | — | No fix listed | CNA |
| expr-eval-fork | expr-eval-fork | up to 3.0.0 | — | No fix listed | CNA |
| — | expr-eval (npm) | up to 2.0.2 | — | No fix listed | GHSA-jc85-fpwf-qm7x |
| — | expr-eval-fork (npm) | before 3.0.1 | 3.0.1 | Patch available | GHSA-jc85-fpwf-qm7x |
- expr-eval Vendorsilentmatt Affected up to 2.0.2 Fixed in — No fix listed CNA
- expr-eval-fork Vendorexpr-eval-fork Affected up to 3.0.0 Fixed in — No fix listed CNA
- expr-eval (npm) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-jc85-fpwf-qm7x
- expr-eval-fork (npm) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-jc85-fpwf-qm7x
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jorenbroekema:javascript_expression_evaluator:3.0.0:*:*:*:*:node.js:*:* | 3.0.0 | Vulnerable | Jorenbroekema |
| cpe:2.3:a:silentmatt:javascript_expression_evaluator:*:*:*:*:*:node.js:*:* | up to 2.0.2 | Vulnerable | silentmatt |
- cpe:2.3:a:jorenbroekema:javascript_expression_evaluator:3.0.0:*:*:*:*:node.js:*:* Versions 3.0.0 Vulnerable ·Jorenbroekema
- cpe:2.3:a:silentmatt:javascript_expression_evaluator:*:*:*:*:*:node.js:*:* Versions up to 2.0.2 Vulnerable ·silentmatt
Remediation
- Fix · GHSA-jc85-fpwf-qm7x expr-eval-fork (npm) Fixed in 3.0.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12735
- 2026-10-03 Alias added: GHSA-jc85-fpwf-qm7x
References
Advisory 4
Other 7
- https://github.com/silentmatt/expr-eval
- https://github.com/jorenbroekema/expr-eval
- https://www.npmjs.com/package/expr-eval-fork
- https://www.npmjs.com/package/expr-eval
- https://github.com/silentmatt/expr-eval/pull/289
- https://github.com/jorenbroekema/expr-eval/commit/1d71bb2ca8f98df8de00e9cc4de8fdd468a7ad43
- https://github.com/jorenbroekema/expr-eval/blob/460b820ba01c5aca6c5d84a7d4f1fa5d1913c67b/test/security.js
More silentmatt Javascript Expression Evaluator vulnerabilities
- TI-2025-12072 Prototype pollution in silentmatt expr-eval CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-12735 · CVE Program
- CVE-2025-12735 · NVD
- FIRST EPSS
- GHSA-jc85-fpwf-qm7x · GitHub Advisory Database · CC BY 4.0
- CVE-2025-12735 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences