Cross-Site Scripting (XSS) in Looker's Extension Loader leading to Admin Account Compromise
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An attacker with viewer permissions in Looker could craft a malicious URL that, when opened by a Looker admin, would execute an attacker-supplied script. Exploitation required at least one Looker extension installed on the instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.18.201+ * 25.0.79+ * 25.6.66+ * 25.12.7+ * 25.16.0+ * 25.18.0+ * 25.20.0+
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Looker | before 24.18.201; before 25.0.79; before 25.6.66; before 25.12.7; before 25.16.0; before 25.18.0; before 25.20.0 | 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0 | Patch available | CNA | |
| Looker | before 24.18.201; before 25.0.79; before 25.6.66; before 25.12.7; before 25.16.0; before 25.18.0; before 25.20.0 | 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0 | Patch available | CNA |
- Looker VendorGoogle Affected before 24.18.201; before 25.0.79; before 25.6.66; before 25.12.7; before 25.16.0; before 25.18.0; before 25.20.0 Fixed in 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0 Patch available CNA
- Looker VendorGoogle Affected before 24.18.201; before 25.0.79; before 25.6.66; before 25.12.7; before 25.16.0; before 25.18.0; before 25.20.0 Fixed in 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0 Patch available CNA
Remediation
- Fix · CNA Looker (Google Cloud) Fixed in 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0
- Fix · CNA Looker (Google Cloud) Fixed in 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, 25.18.0, 25.20.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12739
- 2026-10-03 Alias added: GHSA-mcm3-jr69-vvr3
References
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2025-12739 · CVE Program
- CVE-2025-12739 · NVD
- FIRST EPSS
- GHSA-mcm3-jr69-vvr3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences