Remote Command Execution in Looker via IBM DB2 JDBC drive
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A Looker user with a Developer role could create a database connection using IBM DB2 driver and, by manipulating LookML, cause Looker to execute a malicious command, due to inadequate filtering of the driver's parameters. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 25.0.93+ * 25.6.84+ * 25.12.42+ * 25.14.50+ * 25.16.44+
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Looker | before 25.0.93; before 25.6.84; before 25.12.42; before 25.14.50; before 25.16.44 | 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44 | Patch available | CNA | |
| Looker | before 25.0.93; before 25.6.84; before 25.12.42; before 25.14.50; before 25.16.44 | 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44 | Patch available | CNA |
- Looker VendorGoogle Affected before 25.0.93; before 25.6.84; before 25.12.42; before 25.14.50; before 25.16.44 Fixed in 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44 Patch available CNA
- Looker VendorGoogle Affected before 25.0.93; before 25.6.84; before 25.12.42; before 25.14.50; before 25.16.44 Fixed in 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44 Patch available CNA
Remediation
- Fix · CNA Looker (Google Cloud) Fixed in 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44
- Fix · CNA Looker (Google Cloud) Fixed in 25.0.93, 25.6.84, 25.12.42, 25.14.50, 25.16.44
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12740
- 2026-10-03 Alias added: GHSA-6543-fhjm-g9h2
References
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2025-12740 · CVE Program
- CVE-2025-12740 · NVD
- FIRST EPSS
- GHSA-6543-fhjm-g9h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences