Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | validator | before 13.15.22 | 13.15.22 | Patch available | CNA |
| — | org.webjars.npm:validator | before 13.15.22 | 13.15.22 | Patch available | CNA |
| — | validator (npm) | before 13.15.22 | 13.15.22 | Patch available | GHSA-vghf-hv5q-vc2g |
- validator Vendor— Affected before 13.15.22 Fixed in 13.15.22 Patch available CNA
- org.webjars.npm:validator Vendor— Affected before 13.15.22 Fixed in 13.15.22 Patch available CNA
- validator (npm) Vendor— Affected before 13.15.22 Fixed in 13.15.22 Patch available GHSA-vghf-hv5q-vc2g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:validator_project:validator:*:*:*:*:*:node.js:*:* | before 13.15.22 | Vulnerable | Validator Project |
- cpe:2.3:a:validator_project:validator:*:*:*:*:*:node.js:*:* Versions before 13.15.22 Vulnerable ·Validator Project
Remediation
- Fix · CNA validator Fixed in 13.15.22
- Fix · CNA org.webjars.npm:validator Fixed in 13.15.22
- Fix · GHSA-vghf-hv5q-vc2g validator (npm) Fixed in 13.15.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12758
- 2026-10-03 Alias added: GHSA-vghf-hv5q-vc2g
References
More Validator Project Validator vulnerabilities
- TI-2021-02697 Inefficient Regular Expression Complexity in validatorjs/validator.js CVSS 3.1HIGH 7.5
- TI-2025-35268 A URL validation bypass vulnerability exists in validator.js through version 13.15.15. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2025-12758 · CVE Program
- CVE-2025-12758 · NVD
- FIRST EPSS
- GHSA-vghf-hv5q-vc2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences