aaPanel BaoTa Backend database sql injection
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability has been found in aaPanel BaoTa up to 11.2.x. This vulnerability affects unknown code of the file /database?action=GetDatabaseAccess of the component Backend. The manipulation of the argument Name leads to sql injection. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.3.0 is able to resolve this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA BaoTa (aaPanel) Fixed in 11.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12914
- 2026-10-03 Alias added: GHSA-88w2-6722-q9jg
References
More aaPanel vulnerabilities
- TI-2026-23391 An arbitrary file upload vulnerability in aaPanel v7.57.0 allows attackers to execute… CVSS 3.1CRITICAL 9.8
- TI-2026-65055 aaPanel BaoTa File Merge files.py merge_split_file command injection CVSS 4.0CRITICAL 9.4
- TI-2026-65056 aaPanel BaoTa Unzip panelTask.py panelTask.bt_task._unzip os command injection CVSS 4.0CRITICAL 9.3
- TI-2026-65054 aaPanel BaoTa Database Backup database.py InputSql os command injection CVSS 4.0CRITICAL 9.3
- TI-2026-23390 A lack of path validation in aaPanel v7.57.0 allows attackers to execute a local file… CVSS 3.1HIGH 7.5
- TI-2026-23389 An issue in the VirtualHost configuration handling/parser component of aaPanel v7.57.0… CVSS 3.1HIGH 7.5
Sources
- CVE-2025-12914 · CVE Program
- CVE-2025-12914 · NVD
- FIRST EPSS
- GHSA-88w2-6722-q9jg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences