Improper input validation in NETGEAR DGN2200v4
Priority LOW 32CWE-20Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00268 19th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NETGEAR | DGN2200v4 | up to 1.0.0.126 | — | No fix listed | CNA |
- DGN2200v4 VendorNETGEAR Affected up to 1.0.0.126 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12944
- 2026-10-03 Alias added: GHSA-q26q-g7qp-vmrr
References
More NETGEAR Dgn2200 Firmware vulnerabilities
- TI-2017-03982 ping.cgi on NETGEAR DGN2200 devices with firmware through 10.0.0.50 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-04910 Netgear DGN2200 and DGND3700 disclose the administrator password CVSS 3.0CRITICAL 9.8
- TI-2021-16116 Certain NETGEAR devices are affected by lack of access control at the function level. CVSS 3.1CRITICAL 10.0
- TI-2019-12970 Certain NETGEAR devices allow unauthenticated access to critical .cgi and .htm pages via… CVSS 3.1CRITICAL 9.8
- TI-2024-37767 A vulnerability in the Netgear DGN2200 router with firmware version v1.0.0.46 and earlier… CVSS 3.1HIGH 8.8
- TI-2017-04186 Cross-site request forgery (CSRF) vulnerability in NETGEAR DGN2200 routers with firmware… CVSS 3.0HIGH 8.8
Sources
- CVE-2025-12944 · CVE Program
- CVE-2025-12944 · NVD
- FIRST EPSS
- GHSA-q26q-g7qp-vmrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences