Missing authentication in FluentBit Fluent Bit
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-306.
Summary
Fluent Bit in_forward input plugin does not properly enforce the security.users authentication mechanism under certain configuration conditions. This allows remote attackers with network access to the Fluent Bit instance exposing the forward input to send unauthenticated data. By bypassing authentication controls, attackers can inject forged log records, flood alerting systems, or manipulate routing decisions, compromising the authenticity and integrity of ingested logs.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Fluent Bit (FluentBit) Fixed in 4.0.13
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12969
- 2026-10-03 Alias added: GHSA-2949-r76x-4vc4
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More FluentBit Fluent Bit vulnerabilities
- TI-2024-17419 fluent-bit 2.2.2 contains a Use-After-Free vulnerability in /fluent-bit/plugins/custom_calyptia/calyptia.c. CVSS 3.1HIGH 7.5
- TI-2024-15728 In Fluent Bit 2.1.8 through 2.2.1, a NULL pointer dereference can be caused via an… CVSS 3.1HIGH 7.5
- TI-2024-04026 Fluent Bit Memory Corruption Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2021-21547 An issue was discovered in Treasure Data Fluent Bit 1.7.1, a wrong variable is used to… CVSS 3.1HIGH 7.8
- TI-2021-21546 An issue was discovered in Treasure Data Fluent Bit 1.7.1, erroneous parsing in… CVSS 3.1HIGH 7.8
- TI-2025-21098 An issue in fluent-bit v.3.7.2 allows a local attacker to cause a denial of service via… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2025-12969 · CVE Program
- CVE-2025-12969 · NVD
- FIRST EPSS
- GHSA-2949-r76x-4vc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences