Improper Validation of Specified Quantity in Input in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to cause a denial of service due to excessive resource consumption when processing certain webhook configuration inputs.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.10 to before 18.8.7; 18.9 to before 18.9.3; 18.10 to before 18.10.1 | 18.8.7, 18.9.3, 18.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.10 to before 18.8.7; 18.9 to before 18.9.3; 18.10 to before 18.10.1 Fixed in 18.8.7, 18.9.3, 18.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.10.0 to before 18.8.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.10.0 to before 18.8.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.9.0 to before 18.9.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.9.0 to before 18.9.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:community:*:*:* | 18.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:enterprise:*:*:* | 18.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.10.0 to before 18.8.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.10.0 to before 18.8.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.9.0 to before 18.9.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.9.0 to before 18.9.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:community:*:*:* Versions 18.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.10.0:*:*:*:enterprise:*:*:* Versions 18.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.8.7, 18.9.3, 18.10.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.10.1, 18.8.7, 18.9.3
11 records Highest priority Priority MEDIUM 1 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2026-03452 Inefficient Algorithmic Complexity in GitLabPriority LOW 39
- TI-2026-03343 Cross-Site Request Forgery (CSRF) in GitLabPriority LOW 39
- TI-2026-02350 Authentication Bypass Using an Alternate Path or Channel in GitLabPriority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13078
- 2026-10-03 Alias added: GHSA-237m-4vqc-855x
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-13078 · CVE Program
- CVE-2025-13078 · NVD
- FIRST EPSS
- GHSA-237m-4vqc-855x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences