ury-erp ury pos_extend.py overrided_past_order_list sql injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
A weakness has been identified in ury-erp ury up to 0.2.0. This affects the function overrided_past_order_list of the file ury/ury/api/pos_extend.py. This manipulation of the argument search_term causes sql injection. Remote exploitation of the attack is possible. The exploit has been made available to the public and could be exploited. Upgrading to version 0.2.1 is able to mitigate this issue. Patch name: 063384e0dddfd191847cd2d6524c342cc380b058. It is suggested to upgrade the affected component. The vendor replied and reacted very professional.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ury-erp | ury | 0.1; 0.2.0 | 0.2.1 | Patch available | CNA |
- ury Vendorury-erp Affected 0.1; 0.2.0 Fixed in 0.2.1 Patch available CNA
Remediation
- Fix · CNA ury (ury-erp) Fixed in 0.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13168
- 2026-10-03 Alias added: GHSA-fw37-9qw7-rcpc
References
Sources
- CVE-2025-13168 · CVE Program
- CVE-2025-13168 · NVD
- FIRST EPSS
- GHSA-fw37-9qw7-rcpc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences