Improper Sandboxing in Google Apigee's JavaCallout Policy Allows for Remote Code Execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
A vulnerability exists in Google Apigee's JavaCallout policy https://docs.apigee.com/api-platform/reference/policies/java-callout-policy that allows for remote code execution. It is possible for a user to write a JavaCallout that injected a malicious object into the MessageContext to execute arbitrary Java code and system commands at runtime, leading to unauthorized access to data, lateral movement within the network, and access to backend systems. The Apigee hybrid versions below have all been updated to protect from this vulnerability: * Hybrid_1.11.2+ * Hybrid_1.12.4+ * Hybrid_1.13.3+ * Hybrid_1.14.1+ * OPDK_5202+ * OPDK_5300+
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apigee hybrid Javacallout policy | before Hybrid_1.11.2; before Hybrid_1.12.4; before Hybrid_1.13.3; before Hybrid_1.14.1; before OPDK_5202; before OPDK_5300 | Hybrid_1.11.2, Hybrid_1.12.4, Hybrid_1.13.3, Hybrid_1.14.1, OPDK_5202, OPDK_5300 | Patch available | CNA |
- Apigee hybrid Javacallout policy VendorGoogle Affected before Hybrid_1.11.2; before Hybrid_1.12.4; before Hybrid_1.13.3; before Hybrid_1.14.1; before OPDK_5202; before OPDK_5300 Fixed in Hybrid_1.11.2, Hybrid_1.12.4, Hybrid_1.13.3, Hybrid_1.14.1, OPDK_5202, OPDK_5300 Patch available CNA
Remediation
- Fix · CNA Apigee hybrid Javacallout policy (Google Cloud) Fixed in Hybrid_1.11.2, Hybrid_1.12.4, Hybrid_1.13.3, Hybrid_1.14.1, OPDK_5202, OPDK_5300
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13426
- 2026-10-03 Alias added: GHSA-ppcv-w2rm-62gc
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2025-13426 · CVE Program
- CVE-2025-13426 · NVD
- FIRST EPSS
- GHSA-ppcv-w2rm-62gc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences