Username enumeration through timing difference in mod_wsgi authentication handler
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-208.
Summary
An issue was discovered in 6.0 before 6.0.2, 5.2 before 5.2.11, and 4.2 before 4.2.28. The `django.contrib.auth.handlers.modwsgi.check_password()` function for authentication via `mod_wsgi` allows remote attackers to enumerate users via a timing attack. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Stackered for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.0 to before 6.0.2; 5.2 to before 5.2.11; 4.2 to before 4.2.28 | 6.0.2, 5.2.11, 4.2.28 | Patch available | CNA |
| — | Django (PyPI) | 6.0a1 to before 6.0.2 | 6.0.2 | Patch available | GHSA-2mcm-79hx-8fxw |
| — | Django (PyPI) | 5.2a1 to before 5.2.11 | 5.2.11 | Patch available | GHSA-2mcm-79hx-8fxw |
| — | Django (PyPI) | 4.2a1 to before 4.2.28 | 4.2.28 | Patch available | GHSA-2mcm-79hx-8fxw |
- Django Vendordjangoproject Affected 6.0 to before 6.0.2; 5.2 to before 5.2.11; 4.2 to before 4.2.28 Fixed in 6.0.2, 5.2.11, 4.2.28 Patch available CNA
- Django (PyPI) Vendor— Affected 6.0a1 to before 6.0.2 Fixed in 6.0.2 Patch available GHSA-2mcm-79hx-8fxw
- Django (PyPI) Vendor— Affected 5.2a1 to before 5.2.11 Fixed in 5.2.11 Patch available GHSA-2mcm-79hx-8fxw
- Django (PyPI) Vendor— Affected 4.2a1 to before 4.2.28 Fixed in 4.2.28 Patch available GHSA-2mcm-79hx-8fxw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.28; 5.2 to before 5.2.11; 6.0 to before 6.0.2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.28; 5.2 to before 5.2.11; 6.0 to before 6.0.2 Vulnerable ·djangoproject
Remediation
- Fix · CNA Django (djangoproject) Fixed in 6.0.2, 5.2.11, 4.2.28
- Fix · GHSA-2mcm-79hx-8fxw Django (PyPI) Fixed in 6.0.2 Advisory →
- Fix · GHSA-2mcm-79hx-8fxw Django (PyPI) Fixed in 5.2.11 Advisory →
- Fix · GHSA-2mcm-79hx-8fxw Django (PyPI) Fixed in 4.2.28 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.0.2, 5.2.11, and 4.2.28
6 records Highest priority Priority MEDIUM 2 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-01001 Potential denial-of-service vulnerability in django.utils.text.Truncator HTML methodsPriority MEDIUM 41
- TI-2025-13292 Potential denial-of-service vulnerability via repeated headers when using ASGIPriority MEDIUM 41
- TI-2026-00932 Potential SQL injection via raster lookups on PostGISPriority LOW 39
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13473
- 2026-10-03 Alias added: GHSA-2mcm-79hx-8fxw
References
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-13473 · CVE Program
- CVE-2025-13473 · NVD
- FIRST EPSS
- GHSA-2mcm-79hx-8fxw · GitHub Advisory Database · CC BY 4.0
- CVE-2025-13473 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences