BA Book Everything <= 1.8.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via babe-search-form Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The BA Book Everything plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's babe-search-form shortcode in all versions up to, and including, 1.8.14 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| bookingalgorithms | BA Book Everything | up to 1.8.14 | — | No fix listed | CNA |
- BA Book Everything Vendorbookingalgorithms Affected up to 1.8.14 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:*:*:* | — | — | bookingalgorithms |
- cpe:2.3:a:ba-booking:ba_book_everything:*:*:*:*:*:*:*:* Versions — — ·bookingalgorithms
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14449
- 2026-10-03 Alias added: GHSA-f5xc-6j3j-hf4h
References
More bookingalgorithms vulnerabilities
- TI-2024-08161 BA Book Everything <= 1.6.20 - Cross-Site Request Forgery to Email Address Update/Account Takeover CVSS 3.1HIGH 8.8
- TI-2024-21200 WordPress BA Book Everything plugin <= 1.6.4 - Auth. SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2026-63730 BA Book Everything <= 1.8.27 - Unauthenticated Stored Cross-Site Scripting via first_name Parameter CVSS 3.1HIGH 7.2
- TI-2026-83285 Cross-site scripting in WordPress BA Book Everything plugin CVSS 3.1HIGH 7.1
- TI-2026-66007 BA Book Everything <= 1.8.28 - Unauthenticated Stored Cross-Site Scripting via 'booking_service_qty' Parameter CVSS 3.1HIGH 7.2
- TI-2024-31678 WordPress BA Book Everything plugin <= 1.6.20 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2025-14449 · CVE Program
- CVE-2025-14449 · NVD
- FIRST EPSS
- GHSA-f5xc-6j3j-hf4h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences