Nex-Forms Express WP Form Builder < 9.1.8 - Authenticated Stored XSS
Priority HIGH 65CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The NEX-Forms WordPress plugin before 9.1.8 does not sanitise and escape some of its settings. The NEX-Forms WordPress plugin before 9.1.8 can be configured in such a way that could allow subscribers to perform Stored Cross-Site Scripting.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00287 21st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed NEX-Forms (Unknown): 9.1.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | NEX-Forms | before 9.1.8 | 9.1.8 | Patch available | CNA |
- NEX-Forms VendorUnknown Affected before 9.1.8 Fixed in 9.1.8 Patch available CNA
Remediation
- Fix · CNA NEX-Forms (Unknown) Fixed in 9.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14803
- 2026-10-03 Alias added: GHSA-cp58-32qm-mgjw
References
Sources
- CVE-2025-14803 · CVE Program
- CVE-2025-14803 · NVD
- FIRST EPSS
- GHSA-cp58-32qm-mgjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences