Read the docs
TI-2025-13542 Aliases CVE-2025-14847GHSA-4742-mr57-2r9j

Zlib compressed protocol header length confusion may allow memory read

Priority CRITICAL 95Exploited in the wildCWE-130Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Mismatched length fields in Zlib compressed protocol headers may allow a read of uninitialized heap memory by an unauthenticated client. This issue affects all MongoDB Server v7.0 prior to 7.0.28 versions, MongoDB Server v8.0 versions prior to 8.0.17, MongoDB Server v8.2 versions prior to 8.2.3, MongoDB Server v6.0 versions prior to 6.0.27, MongoDB Server v5.0 versions prior to 5.0.32, MongoDB Server v4.4 versions prior to 4.4.30, MongoDB Server v4.2 versions greater than or equal to 4.2.0, MongoDB Server v4.0 versions greater than or equal to 4.0.0, and MongoDB Server v3.6 versions greater than or equal to 3.6.0.

Why it matters now

Exploitation Active In CISA KEV since 2025-12-29CISA due date 2026-01-19
EPSS 0.83218 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed MongoDB Server (MongoDB Inc.): 8.2.3, 8.0.17, 7.0.28 +3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MongoDBMongoDB Server8.2 to before 8.2.3; 8.0 to before 8.0.17; 7.0 to before 7.0.28; 6.0 to before 6.0.27; 5.0 to before 5.0.32; 4.4 to before 4.4.30; 4.2; 4.0; 3.68.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, 4.4.30Patch availableCNA
  • MongoDB Server VendorMongoDB Affected 8.2 to before 8.2.3; 8.0 to before 8.0.17; 7.0 to before 7.0.28; 6.0 to before 6.0.27; 5.0 to before 5.0.32; 4.4 to before 4.4.30; 4.2; 4.0; 3.6 Fixed in 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, 4.4.30 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:*3.6.0 to before 4.4.30; 5.0.0 to before 5.0.32VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:*6.0.0 to before 6.0.27; 7.0.0 to before 7.0.28; 8.0.0 to before 8.0.17; 8.2.0 to before 8.2.3VulnerableMongoDB
  • cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 3.6.0 to before 4.4.30; 5.0.0 to before 5.0.32 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:*:*:*:*:-:*:*:* Versions 6.0.0 to before 6.0.27; 7.0.0 to before 7.0.28; 8.0.0 to before 8.0.17; 8.2.0 to before 8.2.3 Vulnerable ·MongoDB

Remediation

  • Fix · CNA MongoDB Server (MongoDB Inc.) Fixed in 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, 4.4.30

Timeline

  1. 2025-12-29 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2025-14847
  3. 2026-10-03 Alias added: GHSA-4742-mr57-2r9j

References

  • TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
  • TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
  • TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
  • TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
  • TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
  • TI-2025-02695 MongoDB Server running on Linux may allow unexpected connections where intermediate certificates are revoked CVSS 3.1CRITICAL 9.8
See all 187 →

Sources