Cross-site scripting in wpchill Passster – Password Protect Pages and Content
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.2.21.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14865
- 2026-10-03 Alias added: GHSA-24v5-4jhh-vxrv
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4ea939f5-8b56-44be-bd20-b69e9ded5970?source=cve
- https://plugins.trac.wordpress.org/browser/content-protector/tags/4.2.20/inc/class-ps-public.php#L136
- https://plugins.trac.wordpress.org/changeset/3422595/
- https://plugins.trac.wordpress.org/changeset/3439532/
More wpchill vulnerabilities
- TI-2020-18879 Epsilon Framework Themes (Various Versions) - Function Injection CVSS 3.1CRITICAL 9.8
- TI-2021-07068 Download Monitor < 4.4.5 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-22320 WordPress Download Monitor Plugin <= 4.7.60 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2024-03458 Image Photo Gallery Final Tiles Grid < 3.6.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2021-05950 WordPress Download Monitor plugin <= 4.4.6 - Auth. Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
- TI-2026-03090 Kali Forms <= 2.4.9 - Unauthenticated Remote Code Execution via form_process CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-14865 · CVE Program
- CVE-2025-14865 · NVD
- FIRST EPSS
- GHSA-24v5-4jhh-vxrv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences