wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced. Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided. This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake. The issue affects versions up to and including 5.8.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wolfSSL | wolfSSL-py | 5.3.0 – 5.8.2 | — | No fix listed | CNA |
| — | wolfssl (PyPI) | before 5.8.4.post0 | 5.8.4.post0 | Patch available | GHSA-vj87-jj27-4h9c |
- wolfSSL-py VendorwolfSSL Affected 5.3.0 – 5.8.2 Fixed in — No fix listed CNA
- wolfssl (PyPI) Vendor— Affected before 5.8.4.post0 Fixed in 5.8.4.post0 Patch available GHSA-vj87-jj27-4h9c
Remediation
- Fix · GHSA-vj87-jj27-4h9c wolfssl (PyPI) Fixed in 5.8.4.post0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15346
- 2026-10-03 Alias added: GHSA-vj87-jj27-4h9c
References
More wolfSSL vulnerabilities
- TI-2024-00830 SEGV and out of bounds memory read from malicious packet CVSS 3.1CRITICAL 9.1
- TI-2009-04246 Multiple stack-based buffer overflows in the CertDecoder::GetName function in src/asn.cpp… CVSS 2.0HIGH 7.5
- TI-2022-18557 In wolfSSL before 5.5.1, malicious clients can cause a buffer overflow during a TLS 1.3… CVSS 3.1HIGH 7.5
- TI-2025-10943 Potential DoS Vulnerability through Multiple KeyShareEntry with Same Group in TLS 1.3 ClientHello CVSS 4.0MEDIUM 6.3
- TI-2017-09737 wolfSSL Bleichenbacher/ROBOT CVSS 3.0HIGH 7.5
- TI-2019-08902 wolfSSL 4.0.0 has a Buffer Overflow in DoPreSharedKeys in tls13.c when a current identity… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-15346 · CVE Program
- CVE-2025-15346 · NVD
- FIRST EPSS
- GHSA-vj87-jj27-4h9c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences