Library Viewer < 3.2.0 - Reflected Cross-Site Scripting
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Library Viewer WordPress plugin before 3.2.0 does not sanitise and escape some parameters before outputting them back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00252 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Library Viewer (Unknown): 3.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Library Viewer | before 3.2.0 | 3.2.0 | Patch available | CNA |
- Library Viewer VendorUnknown Affected before 3.2.0 Fixed in 3.2.0 Patch available CNA
Remediation
- Fix · CNA Library Viewer (Unknown) Fixed in 3.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15396
- 2026-10-03 Alias added: GHSA-94gf-82q2-rv5g
References
Sources
- CVE-2025-15396 · CVE Program
- CVE-2025-15396 · NVD
- FIRST EPSS
- GHSA-94gf-82q2-rv5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences