Responsive Plus < 3.4.3 - Unauthenticated Arbitrary Shortcode Execution
Priority HIGH 68Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Responsive Plus WordPress plugin before 3.4.3 is vulnerable to arbitrary shortcode execution due to the software allowing unauthenticated users to execute the update_responsive_woo_free_shipping_left_shortcode AJAX action that does not properly validate the content_rech_data parameter before processing it as a shortcode.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00329 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Responsive Plus (Unknown): 3.4.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Responsive Plus | before 3.4.3 | 3.4.3 | Patch available | CNA |
- Responsive Plus VendorUnknown Affected before 3.4.3 Fixed in 3.4.3 Patch available CNA
Remediation
- Fix · CNA Responsive Plus (Unknown) Fixed in 3.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15488
- 2026-10-03 Alias added: GHSA-cph7-rc62-v42q
References
Sources
- CVE-2025-15488 · CVE Program
- CVE-2025-15488 · NVD
- FIRST EPSS
- GHSA-cph7-rc62-v42q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences