Dataease SQLBot API Endpoint assistant.py access control
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-266 and CWE-284.
Summary
A vulnerability has been found in Dataease SQLBot up to 1.4.0. This affects an unknown function of the file backend/apps/system/api/assistant.py of the component API Endpoint. Such manipulation leads to improper access controls. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.0 mitigates this issue. The name of the patch is d640ac31d1ce64ce90e06cf7081163915c9fc28c. Upgrading the affected component is recommended. Multiple endpoints are affected. The vendor was contacted early about this disclosure.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dataease | SQLBot | 1.0; 1.1; 1.2; 1.3; 1.4.0 | 1.5.0 | Patch available | CNA |
- SQLBot Vendordataease Affected 1.0; 1.1; 1.2; 1.3; 1.4.0 Fixed in 1.5.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:sqlbot:*:*:*:*:*:*:*:* | before 1.5.0 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:sqlbot:*:*:*:*:*:*:*:* Versions before 1.5.0 Vulnerable ·1Panel-dev
Remediation
- Fix · CNA SQLBot (Dataease) Fixed in 1.5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15597
- 2026-10-03 Alias added: GHSA-7gmx-vw6r-9xrm
References
Exploit 3
Patch 2
More dataease vulnerabilities
- TI-2024-38037 An issue in DataEase v1 allows an attacker to execute arbitrary code via the user account and password components. CVSS 3.1CRITICAL 9.8
- TI-2023-12981 SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed CVSS 3.1CRITICAL 9.8
- TI-2022-18688 Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-24677 Dataease: Redshift JDBC RCE Bypass CVSS 4.0CRITICAL 9.3
- TI-2026-24674 DataEase SQL Injection Vulnerability CVSS 4.0CRITICAL 9.3
- TI-2024-37398 DataEase has an unauthorized vulnerability CVSS 4.0CRITICAL 9.3
Sources
- CVE-2025-15597 · CVE Program
- CVE-2025-15597 · NVD
- FIRST EPSS
- GHSA-7gmx-vw6r-9xrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences