Popup Box AYS Pro < 5.5.0 - Admin+ Stored Cross-Site Scripting (XSS) via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Popup Box WordPress plugin before 5.5.0 does not properly validate nonces in the add_or_edit_popupbox() function before saving popup data, allowing unauthenticated attackers to perform Cross-Site Request Forgery attacks. When an authenticated admin visits a malicious page, the attacker can create or modify popups with arbitrary JavaScript that executes in the admin panel and frontend.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Popup Box | before 5.5.0 | 5.5.0 | Patch available | CNA |
- Popup Box VendorUnknown Affected before 5.5.0 Fixed in 5.5.0 Patch available CNA
Remediation
- Fix · CNA Popup Box (Unknown) Fixed in 5.5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15611
- 2026-10-03 Alias added: GHSA-86pc-m9xh-3jg9
References
More Ays Pro Popup Box vulnerabilities
- TI-2024-08906 Popup Box < 4.7.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-05409 Popup box < 3.8.6 - Admin+ Stored XSS in Popup Settings CVSS 3.1MEDIUM 4.8
- TI-2023-04916 Popup Box < 3.7.9 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-04056 Popup box < 3.7.2 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2021-06749 Popup Like box - Page Plugin < 3.5.3 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
- TI-2021-06747 Popup box < 2.3.4 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
Sources
- CVE-2025-15611 · CVE Program
- CVE-2025-15611 · NVD
- FIRST EPSS
- GHSA-86pc-m9xh-3jg9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences