Content Protector (Passster) < 4.3.7 - Contributor+ Protected Content Disclosure via Core REST API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
The Passster WordPress plugin before 4.3.7 does not restrict low-privilege users holding the edit_posts capability from reading globally password-protected content through the WordPress core REST API when global protection is enabled, allowing any Contributor or higher to read the content of protected pages and posts without knowing the password.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Passster | before 4.3.7 | 4.3.7 | Patch available | CNA |
- Passster VendorUnknown Affected before 4.3.7 Fixed in 4.3.7 Patch available CNA
Remediation
- Fix · CNA Passster (Unknown) Fixed in 4.3.7
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15674
- 2026-10-03 Alias added: GHSA-wqxf-2hrv-jrwq
References
Sources
- CVE-2025-15674 · CVE Program
- CVE-2025-15674 · NVD
- FIRST EPSS
- GHSA-wqxf-2hrv-jrwq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences