Content Mask 1.7.1 - 1.8.5.5 - Contributor+ Stored XSS via Post Scripts and Styles
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Content Mask WordPress plugin before 1.8.5.6 does not properly sanitise and escape content submitted with a post before outputting it in the pages it generates, allowing users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks against any user viewing or previewing the affected page. The Content Mask WordPress plugin before 1.8.5.6's option to restrict its use by role does not prevent this.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Content Mask | 1.7.1 to before 1.8.5.6 | 1.8.5.6 | Patch available | CNA |
- Content Mask VendorUnknown Affected 1.7.1 to before 1.8.5.6 Fixed in 1.8.5.6 Patch available CNA
Remediation
- Fix · CNA Content Mask (Unknown) Fixed in 1.8.5.6
Timeline
- 2026-10-02 Threatist record created from CVE-2025-15690
- 2026-10-03 Alias added: GHSA-4pc2-5jpc-www8
References
Sources
- CVE-2025-15690 · CVE Program
- CVE-2025-15690 · NVD
- FIRST EPSS
- GHSA-4pc2-5jpc-www8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences