Read the docs
TI-2025-14312 Aliases CVE-2025-15695GHSA-4gfq-34p6-73xj

GTranslate < 3.0.10 - Admin+ Stored XSS

Priority LOW 16CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Translate WordPress with GTranslate WordPress plugin before 3.0.10 does not validate one of its settings before the bundled front-end scripts build markup from it, allowing users with a role as high as administrator to store JavaScript that runs in the session of any visitor to the site.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00242 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Translate WordPress with GTranslate (Unknown): 3.0.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownTranslate WordPress with GTranslatebefore 3.0.103.0.10Patch availableCNA
  • Translate WordPress with GTranslate VendorUnknown Affected before 3.0.10 Fixed in 3.0.10 Patch available CNA

Remediation

  • Fix · CNA Translate WordPress with GTranslate (Unknown) Fixed in 3.0.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-15695
  2. 2026-10-03 Alias added: GHSA-4gfq-34p6-73xj

References

Sources