Arbitrary file read via block duplication in Mattermost Boards
Priority MEDIUM 44CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate input when patching and duplicating a board, which allows a user to read any arbitrary file on the system via duplicating a specially crafted block in Boards.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00611 49th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 10.5.0, 10.4.2, 9.11.8 +2github.com/mattermost/mattermost/server/v8 (Go): 8.0.0-20250122165010-4ed702ccff4e, 9.11.8, 10.2.3 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.4.0 – 10.4.1; 9.11.0 – 9.11.7; 10.3.0 – 10.3.2; 10.2.0 – 10.2.2 | 10.5.0, 10.4.2, 9.11.8, 10.3.3, 10.2.3 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20250122165010-4ed702ccff4e | 8.0.0-20250122165010-4ed702ccff4e | Patch available | GHSA-v469-7wp6-7cvp |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.11.0-rc1 to before 9.11.8 | 9.11.8 | Patch available | GHSA-v469-7wp6-7cvp |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.2.0-rc1 to before 10.2.3 | 10.2.3 | Patch available | GHSA-v469-7wp6-7cvp |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.3.0-rc1 to before 10.3.3 | 10.3.3 | Patch available | GHSA-v469-7wp6-7cvp |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 10.4.0-rc1 to before 10.4.2 | 10.4.2 | Patch available | GHSA-v469-7wp6-7cvp |
- Mattermost VendorMattermost Affected 10.4.0 – 10.4.1; 9.11.0 – 9.11.7; 10.3.0 – 10.3.2; 10.2.0 – 10.2.2 Fixed in 10.5.0, 10.4.2, 9.11.8, 10.3.3, 10.2.3 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20250122165010-4ed702ccff4e Fixed in 8.0.0-20250122165010-4ed702ccff4e Patch available GHSA-v469-7wp6-7cvp
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.11.0-rc1 to before 9.11.8 Fixed in 9.11.8 Patch available GHSA-v469-7wp6-7cvp
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.2.0-rc1 to before 10.2.3 Fixed in 10.2.3 Patch available GHSA-v469-7wp6-7cvp
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.3.0-rc1 to before 10.3.3 Fixed in 10.3.3 Patch available GHSA-v469-7wp6-7cvp
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 10.4.0-rc1 to before 10.4.2 Fixed in 10.4.2 Patch available GHSA-v469-7wp6-7cvp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 9.11.0 to before 9.11.8; 10.2.0 to before 10.2.3; 10.3.0 to before 10.3.3; 10.4.0 to before 10.4.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 9.11.0 to before 9.11.8; 10.2.0 to before 10.2.3; 10.3.0 to before 10.3.3; 10.4.0 to before 10.4.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 10.5.0, 10.4.2, 9.11.8, 10.3.3, 10.2.3
- Fix · GHSA-v469-7wp6-7cvp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20250122165010-4ed702ccff4e Advisory →
- Fix · GHSA-v469-7wp6-7cvp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.11.8 Advisory →
- Fix · GHSA-v469-7wp6-7cvp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.2.3 Advisory →
- Fix · GHSA-v469-7wp6-7cvp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.3.3 Advisory →
- Fix · GHSA-v469-7wp6-7cvp github.com/mattermost/mattermost/server/v8 (Go) Fixed in 10.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-20051
- 2026-10-03 Alias added: GHSA-v469-7wp6-7cvp
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2018-15213 An issue was discovered in Mattermost Server before 5.2 and 5.1.1. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-20051 · CVE Program
- CVE-2025-20051 · NVD
- FIRST EPSS
- GHSA-v469-7wp6-7cvp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences