Reflected Cross-Site Scripting (XSS) on Splunk Enterprise through dashboard PDF generation component
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
In Splunk Enterprise versions below 9.4.2, 9.3.4 and 9.2.6, and Splunk Cloud Platform versions below 9.3.2411.102, 9.3.2408.111 and 9.2.2406.118, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through the pdfgen/render REST endpoint that could result in execution of unauthorized JavaScript code in the browser of a user.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Splunk | Splunk Enterprise | 9.4 to before 9.4.2; 9.3 to before 9.3.4; 9.2 to before 9.2.6; 9.1 to before 9.1.9 | 9.4.2, 9.3.4, 9.2.6, 9.1.9 | Patch available | CNA |
| Splunk | Splunk Cloud Platform | 9.3.2411 to before 9.3.2411.102; 9.3.2408 to before 9.3.2408.111; 9.2.2406 to before 9.2.2406.118 | 9.3.2411.102, 9.3.2408.111, 9.2.2406.118 | Patch available | CNA |
- Splunk Enterprise VendorSplunk Affected 9.4 to before 9.4.2; 9.3 to before 9.3.4; 9.2 to before 9.2.6; 9.1 to before 9.1.9 Fixed in 9.4.2, 9.3.4, 9.2.6, 9.1.9 Patch available CNA
- Splunk Cloud Platform VendorSplunk Affected 9.3.2411 to before 9.3.2411.102; 9.3.2408 to before 9.3.2408.111; 9.2.2406 to before 9.2.2406.118 Fixed in 9.3.2411.102, 9.3.2408.111, 9.2.2406.118 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* | 9.2.0 to before 9.2.6; 9.3.0 to before 9.3.4; 9.4.0 to before 9.4.2 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* | 9.2.2406 to before 9.2.2406.118; 9.3.2408 to before 9.3.2408.111; 9.3.2411 to before 9.3.2411.102 | Vulnerable | Splunk |
- cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:* Versions 9.2.0 to before 9.2.6; 9.3.0 to before 9.3.4; 9.4.0 to before 9.4.2 Vulnerable ·Splunk
- cpe:2.3:a:splunk:splunk_cloud_platform:*:*:*:*:*:*:*:* Versions 9.2.2406 to before 9.2.2406.118; 9.3.2408 to before 9.3.2408.111; 9.3.2411 to before 9.3.2411.102 Vulnerable ·Splunk
Remediation
- Fix · CNA Splunk Enterprise (Splunk) Fixed in 9.4.2, 9.3.4, 9.2.6, 9.1.9
- Fix · CNA Splunk Cloud Platform (Splunk) Fixed in 9.3.2411.102, 9.3.2408.111, 9.2.2406.118
Timeline
- 2026-10-02 Threatist record created from CVE-2025-20297
- 2026-10-03 Alias added: GHSA-3r93-v644-8g5h
References
More Splunk vulnerabilities
- TI-2026-16444 Unauthenticated Arbitrary File Creation and Truncation in a PostgreSQL Sidecar Service Endpoint in Splunk Enterprise KEVCVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2023-24841 Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing CVSS 3.1HIGH 8.8
- TI-2023-15979 ‘edit_user’ Capability Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-30707 Remote Code Execution (RCE) due to insecure session storage configuration in Splunk Enterprise on Windows CVSS 3.1HIGH 8.8
- TI-2022-21345 Reflected Cross-Site Scripting via the radio template in Splunk Enterprise CVSS 3.1HIGH 8.8
Sources
- CVE-2025-20297 · CVE Program
- CVE-2025-20297 · NVD
- FIRST EPSS
- GHSA-3r93-v644-8g5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences