NFC: nci: Add bounds checking in nci_hci_create_pipe()
Priority LOW 38CWE-787Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: NFC: nci: Add bounds checking in nci_hci_create_pipe() The "pipe" variable is a u8 which comes from the network. If it's more than 127, then it results in memory corruption in the caller, nci_hci_connect_gate().
Why it matters now
EPSS 0.0038 32nd percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.291, 5.10.235, 5.15.179 +5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.4 and later | 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.78, 6.12.14, 6.13.3, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 4.4 and later Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.78, 6.12.14, 6.13.3, 6.14 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.4 to before 6.1.129; 6.2 to before 6.6.78; 6.7 to before 6.12.14; 6.13 to before 6.13.3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.4 to before 6.1.129; 6.2 to before 6.6.78; 6.7 to before 6.12.14; 6.13 to before 6.13.3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.78, 6.12.14, 6.13.3, 6.14
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21735
- 2026-10-03 Alias added: GHSA-63p9-c49j-px3q
References
Patch 5
- https://git.kernel.org/stable/c/d5a461c315e5ff92657f84d8ba50caa5abf5c22a
- https://git.kernel.org/stable/c/172cdfc3a5ea20289c58fb73dadc6fd4a8784a4e
- https://git.kernel.org/stable/c/2ae4bade5a64d126bd18eb66bd419005c5550218
- https://git.kernel.org/stable/c/59c7ed20217c0939862fbf8145bc49d5b3a13f4f
- https://git.kernel.org/stable/c/110b43ef05342d5a11284cc8b21582b698b4ef1c
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-21735 · CVE Program
- CVE-2025-21735 · NVD
- FIRST EPSS
- GHSA-63p9-c49j-px3q · GitHub Advisory Database · CC BY 4.0
- CVE-2025-21735 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences