openvswitch: use RCU protection in ovs_vport_cmd_fill_info()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 fixed, 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: openvswitch: use RCU protection in ovs_vport_cmd_fill_info() ovs_vport_cmd_fill_info() can be called without RTNL or RCU. Use RCU protection and dev_net_rcu() to avoid potential UAF.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.15 and later | 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 4.15 and later Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.15 to before 5.4.291; 5.5 to before 5.10.235; 5.11 to before 5.15.179; 5.16 to before 6.1.129; 6.2 to before 6.6.79; 6.7 to before 6.12.16; 6.13 to before 6.13.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* | 6.14 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* | 6.14 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.15 to before 5.4.291; 5.5 to before 5.10.235; 5.11 to before 5.15.179; 5.16 to before 6.1.129; 6.2 to before 6.6.79; 6.7 to before 6.12.16; 6.13 to before 6.13.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* Versions 6.14 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* Versions 6.14 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14
Red Hat 1 advisory
- RHSA-2025:20095 Released 2025-11-11 · Red Hat rating Moderatekernel security update
- Red Hat Enterprise Linux AppStream (v. 10) kernel-64k-debug-devel-6.12.0-124.8.1.el10_1, kernel-64k-debug-devel-matched-6.12.0-124.8.1.el10_1, kernel-64k-devel-6.12.0-124.8.1.el10_1 +12
- Red Hat Enterprise Linux BaseOS (v. 10) kernel-6.12.0-124.8.1.el10_1, kernel-64k-6.12.0-124.8.1.el10_1, kernel-64k-core-6.12.0-124.8.1.el10_1 +29
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) kernel-tools-libs-devel-6.12.0-124.8.1.el10_1, libperf-6.12.0-124.8.1.el10_1
- Red Hat Enterprise Linux Real Time (v. 10) kernel-rt-6.12.0-124.8.1.el10_1, kernel-rt-64k-6.12.0-124.8.1.el10_1, kernel-rt-64k-core-6.12.0-124.8.1.el10_1 +21
- Red Hat Enterprise Linux Real Time for NFV (v. 10) kernel-rt-6.12.0-124.8.1.el10_1, kernel-rt-core-6.12.0-124.8.1.el10_1, kernel-rt-debug-6.12.0-124.8.1.el10_1 +9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:20095 |
| Red Hat Enterprise Linux BaseOS (v. 10) | Fixed | RHSA-2025:20095 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2025:20095 |
| Red Hat Enterprise Linux Real Time (v. 10) | Fixed | RHSA-2025:20095 |
| Red Hat Enterprise Linux Real Time for NFV (v. 10) | Fixed | RHSA-2025:20095 |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21761
- 2026-10-03 Alias added: GHSA-q6cq-g5qv-hwc8
References
Patch 8
- https://git.kernel.org/stable/c/e85a25d1a9985645e796039e843d1de581d2de1e
- https://git.kernel.org/stable/c/a8816b3f1f151373fd30f1996f00480126c8bb11
- https://git.kernel.org/stable/c/a884f57600e463f69d7b279c4598b865260b62a1
- https://git.kernel.org/stable/c/7e01abc34e87abd091e619161a20f54ed4e3e2da
- https://git.kernel.org/stable/c/8ec57509c36c8b9a23e50b7858dda0c520a2d074
- https://git.kernel.org/stable/c/a849a10de5e04d798f7f286a2f1ca174719a617a
- https://git.kernel.org/stable/c/5828937742af74666192835d657095d95c53dbd0
- https://git.kernel.org/stable/c/90b2f49a502fa71090d9f4fe29a2f51fe5dff76d
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-21761 · CVE Program
- CVE-2025-21761 · NVD
- FIRST EPSS
- GHSA-q6cq-g5qv-hwc8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-21761 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences