ipv4: use RCU protection in __ip_rt_update_pmtu()
Priority LOW 38Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: ipv4: use RCU protection in __ip_rt_update_pmtu() __ip_rt_update_pmtu() must use RCU protection to make sure the net structure it reads does not disappear.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0057 47th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.15, 4.20, 5.5 +7Red Hat: 5 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.14.200 to before 4.15; 4.19.148 to before 4.20; 5.4.68 to before 5.5; 5.8.12 to before 5.9 | 4.15, 4.20, 5.5, 5.9 | Patch available | CNA |
| Linux | Linux | 5.9 and later | 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 4.14.200 to before 4.15; 4.19.148 to before 4.20; 5.4.68 to before 5.5; 5.8.12 to before 5.9 Fixed in 4.15, 4.20, 5.5, 5.9 Patch available CNA
- Linux VendorLinux Affected 5.9 and later Fixed in 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.200 to before 4.15; 4.19.148 to before 4.20; 5.4.68 to before 5.5; 5.8.12 to before 5.9; 5.9.1 to before 5.15.179; 5.16 to before 6.1.129; 6.2 to before 6.6.79; 6.7 to before 6.12.16; 6.13 to before 6.13.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* | 5.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* | 5.9 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* | 5.9 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* | 6.14 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* | 6.14 rc2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.200 to before 4.15; 4.19.148 to before 4.20; 5.4.68 to before 5.5; 5.8.12 to before 5.9; 5.9.1 to before 5.15.179; 5.16 to before 6.1.129; 6.2 to before 6.6.79; 6.7 to before 6.12.16; 6.13 to before 6.13.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:-:*:*:*:*:*:* Versions 5.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc7:*:*:*:*:*:* Versions 5.9 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.9:rc8:*:*:*:*:*:* Versions 5.9 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* Versions 6.14 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* Versions 6.14 rc2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.15, 4.20, 5.5, 5.9
- Fix · CNA Linux (Linux) Fixed in 5.15.179, 6.1.129, 6.6.79, 6.12.16, 6.13.4, 6.14
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21766
- 2026-10-03 Alias added: GHSA-7r26-6h4q-5x56
- 2026-10-16 CISA SSVC decision points changed
References
Patch 6
- https://git.kernel.org/stable/c/ce3c6165fce0f06305c806696882a3ad4b90e33f
- https://git.kernel.org/stable/c/ea07480b23225942208f1b754fea1e7ec486d37e
- https://git.kernel.org/stable/c/9b1766d1ff5fe496aabe9fc5f4e34e53f35c11c4
- https://git.kernel.org/stable/c/4583748b65dee4d61bd50a2214715b4237bc152a
- https://git.kernel.org/stable/c/a39f61d212d822b3062d7f70fa0588e50e55664e
- https://git.kernel.org/stable/c/139512191bd06f1b496117c76372b2ce372c9a41
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-21766 · CVE Program
- CVE-2025-21766 · NVD
- FIRST EPSS
- GHSA-7r26-6h4q-5x56 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-21766 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences