USB: gadget: f_midi: f_midi_complete to call queue_work
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-667 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: USB: gadget: f_midi: f_midi_complete to call queue_work When using USB MIDI, a lock is attempted to be acquired twice through a re-entrant call to f_midi_transmit, causing a deadlock. Fix it by using queue_work() to schedule the inner f_midi_transmit() via a high priority work queue from the completion handler.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.2 and later | 5.4.291, 5.10.235, 5.15.179, 6.1.130, 6.6.80, 6.12.17, 6.13.5, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 3.2 and later Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.130, 6.6.80, 6.12.17, 6.13.5, 6.14 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.2 to before 6.1.130; 6.2 to before 6.6.80; 6.7 to before 6.12.17; 6.13 to before 6.13.5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* | 6.14 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* | 6.14 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* | 6.14 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.2 to before 6.1.130; 6.2 to before 6.6.80; 6.7 to before 6.12.17; 6.13 to before 6.13.5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* Versions 6.14 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* Versions 6.14 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* Versions 6.14 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.291, 5.10.235, 5.15.179, 6.1.130, 6.6.80, 6.12.17, 6.13.5, 6.14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21859
- 2026-10-03 Alias added: GHSA-r5hj-8p6x-9rq8
References
Patch 8
- https://git.kernel.org/stable/c/727dee0857946b85232526de4f5a957fe163e89a
- https://git.kernel.org/stable/c/1f10923404705a94891e612dff3b75e828a78368
- https://git.kernel.org/stable/c/b09957657d7767d164b3432af2129bd72947553c
- https://git.kernel.org/stable/c/24a942610ee9bafb2692a456ae850c5b2e409b05
- https://git.kernel.org/stable/c/deeee3adb2c01eedab32c3b4519337689ad02e8a
- https://git.kernel.org/stable/c/e9fec6f42c45db2f62dc373fb1a10d2488c04e79
- https://git.kernel.org/stable/c/8aa6b4be1f4efccbfc533e6ec8841d26e4fa8dba
- https://git.kernel.org/stable/c/4ab37fcb42832cdd3e9d5e50653285ca84d6686f
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-21859 · CVE Program
- CVE-2025-21859 · NVD
- FIRST EPSS
- GHSA-r5hj-8p6x-9rq8 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-21859 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences