Read the docs
TI-2025-15907 Aliases CVE-2025-21957GHSA-6xj5-r9h7-wphq

scsi: qla1280: Fix kernel oops when debug level > 2

Priority LOW 24CWE-476Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-476.

Summary

In the Linux kernel, the following vulnerability has been resolved: scsi: qla1280: Fix kernel oops when debug level > 2 A null dereference or oops exception will eventually occur when qla1280.c driver is compiled with DEBUG_QLA1280 enabled and ql_debug_level > 2. I think its clear from the code that the intention here is sg_dma_len(s) not length of sg_next(s) when printing the debug info.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00233 14th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.292, 5.10.236, 5.15.180 +5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux2.6.24 and later5.4.292, 5.10.236, 5.15.180, 6.1.132, 6.6.84, 6.12.20, 6.13.8, 6.14Patch availableCNA
  • Linux VendorLinux Affected 2.6.24 and later Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.132, 6.6.84, 6.12.20, 6.13.8, 6.14 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.132; 6.2 to before 6.6.84; 6.7 to before 6.12.20; 6.13 to before 6.13.8VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:*6.14 rc1VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.132; 6.2 to before 6.6.84; 6.7 to before 6.12.20; 6.13 to before 6.13.8 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* Versions 6.14 rc1 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.132, 6.6.84, 6.12.20, 6.13.8, 6.14

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-21957
  2. 2026-10-03 Alias added: GHSA-6xj5-r9h7-wphq

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources