ksmbd: fix incorrect validation for num_aces field of smb_acl
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix incorrect validation for num_aces field of smb_acl parse_dcal() validate num_aces to allocate posix_ace_state_array. if (num_aces > ULONG_MAX / sizeof(struct smb_ace *)) It is an incorrect validation that we can create an array of size ULONG_MAX. smb_acl has ->size field to calculate actual number of aces in request buffer size. Use this to check invalid num_aces.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15 and later | 5.15.180, 6.1.132, 6.6.85, 6.12.21, 6.13.9, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 5.15 and later Fixed in 5.15.180, 6.1.132, 6.6.85, 6.12.21, 6.13.9, 6.14 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15 to before 5.15.180; 5.16 to before 6.1.132; 6.2 to before 6.6.85; 6.7 to before 6.12.21; 6.13 to before 6.13.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* | 6.14 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* | 6.14 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* | 6.14 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* | 6.14 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* | 6.14 rc5 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15 to before 5.15.180; 5.16 to before 6.1.132; 6.2 to before 6.6.85; 6.7 to before 6.12.21; 6.13 to before 6.13.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc1:*:*:*:*:*:* Versions 6.14 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc2:*:*:*:*:*:* Versions 6.14 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc3:*:*:*:*:*:* Versions 6.14 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc4:*:*:*:*:*:* Versions 6.14 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc5:*:*:*:*:*:* Versions 6.14 rc5 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.180, 6.1.132, 6.6.85, 6.12.21, 6.13.9, 6.14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-21994
- 2026-10-03 Alias added: GHSA-pcv3-r2v8-4964
References
Patch 6
- https://git.kernel.org/stable/c/c3a3484d9d31b27a3db0fab91fcf191132d65236
- https://git.kernel.org/stable/c/9c4e202abff45f8eac17989e549fc7a75095f675
- https://git.kernel.org/stable/c/d0f87370622a853b57e851f7d5a5452b72300f19
- https://git.kernel.org/stable/c/a4cb17797a5d241f1e509cb5b46ed95a80c2f5fd
- https://git.kernel.org/stable/c/f6a6721802ac2f12f4c1bbe839a4c229b61866f2
- https://git.kernel.org/stable/c/1b8b67f3c5e5169535e26efedd3e422172e2db64
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-21994 · CVE Program
- CVE-2025-21994 · NVD
- FIRST EPSS
- GHSA-pcv3-r2v8-4964 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-21994 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences