ksmbd: validate zero num_subauth before sub_auth is accessed
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ksmbd: validate zero num_subauth before sub_auth is accessed Access psid->sub_auth[psid->num_subauth - 1] without checking if num_subauth is non-zero leads to an out-of-bounds read. This patch adds a validation step to ensure num_subauth != 0 before sub_auth is accessed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15 and later | 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 5.15 and later Fixed in 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22038
- 2026-10-03 Alias added: GHSA-8xw7-j864-h87q
References
Patch 6
- https://git.kernel.org/stable/c/3ac65de111c686c95316ade660f8ba7aea3cd3cc
- https://git.kernel.org/stable/c/0e36a3e080d6d8bd7a34e089345d043da4ac8283
- https://git.kernel.org/stable/c/56de7778a48560278c334077ace7b9ac4bfb2fd1
- https://git.kernel.org/stable/c/68c6c3142bfcdb049839d40a9a59ebe8ea865002
- https://git.kernel.org/stable/c/c8bfe1954a0b89e7b29b3a3e7f4c5e0ebd295e20
- https://git.kernel.org/stable/c/bf21e29d78cd2c2371023953d9c82dfef82ebb36
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-22038 · CVE Program
- CVE-2025-22038 · NVD
- FIRST EPSS
- GHSA-8xw7-j864-h87q · GitHub Advisory Database · CC BY 4.0
- CVE-2025-22038 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences