spufs: fix a leak in spufs_create_context()
Priority LOW 24CWE-401Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: spufs: fix a leak in spufs_create_context() Leak fixes back in 2008 missed one case - if we are trying to set affinity and spufs_mkdir() fails, we need to drop the reference to neighbor.
Why it matters now
EPSS 0.0024 15th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.292, 5.10.236, 5.15.180 +6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.25 and later | 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.25 and later Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.25 to before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.25 to before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15
Vendor assessments
Red Hat
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22071
- 2026-10-03 Alias added: GHSA-r24q-wpfh-2vqx
References
Patch 9
- https://git.kernel.org/stable/c/829bd6139968e2e759f3928cf65ad0db1e302fe3
- https://git.kernel.org/stable/c/410c787d89c92df4215d7b1a338e2c1a8aba6b9b
- https://git.kernel.org/stable/c/c4e72a0d75442237b6f3bcca10a7d81b89376d16
- https://git.kernel.org/stable/c/a333f223e555d27609f8b45d75a08e8e1d36c432
- https://git.kernel.org/stable/c/239ea3c34673b3244a499fd65771c47e5bffcbb0
- https://git.kernel.org/stable/c/d04600f43569d48262e1328eaa1592fcefa2c19c
- https://git.kernel.org/stable/c/5a90b699844a5bb96961e5892e51cc59255444a3
- https://git.kernel.org/stable/c/4a7448c83e117ed68597952ecaede1cebc4427a7
- https://git.kernel.org/stable/c/0f5cce3fc55b08ee4da3372baccf4bcd36a98396
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-22071 · CVE Program
- CVE-2025-22071 · NVD
- FIRST EPSS
- GHSA-r24q-wpfh-2vqx · GitHub Advisory Database · CC BY 4.0
- CVE-2025-22071 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences