ocfs2: validate l_tree_depth to avoid out-of-bounds access
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ocfs2: validate l_tree_depth to avoid out-of-bounds access The l_tree_depth field is 16-bit (__le16), but the actual maximum depth is limited to OCFS2_MAX_PATH_DEPTH. Add a check to prevent out-of-bounds access if l_tree_depth has an invalid value, which may occur when reading from a corrupted mounted disk [1].
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.16 and later | 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.16 and later Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.16 to before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.16 to before 5.4.292; 5.5 to before 5.10.236; 5.11 to before 5.15.180; 5.16 to before 6.1.134; 6.2 to before 6.6.87; 6.7 to before 6.12.23; 6.13 to before 6.13.11; 6.14 to before 6.14.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.292, 5.10.236, 5.15.180, 6.1.134, 6.6.87, 6.12.23, 6.13.11, 6.14.2, 6.15
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22079
- 2026-10-03 Alias added: GHSA-h8h5-wj84-22hp
- 2026-11-07 Affected versions changed · Red Hat
References
Patch 9
- https://git.kernel.org/stable/c/ef34840bda333fe99bafbd2d73b70ceaaf9eba66
- https://git.kernel.org/stable/c/538ed8b049ef801a86c543433e5061a91cc106e3
- https://git.kernel.org/stable/c/17c99ab3db2ba74096d36c69daa6e784e98fc0b8
- https://git.kernel.org/stable/c/11e24802e73362aa2948ee16b8fb4e32635d5b2a
- https://git.kernel.org/stable/c/3d012ba4404a0bb517658699ba85e6abda386dc3
- https://git.kernel.org/stable/c/49d2a2ea9d30991bae82107f9523915b91637683
- https://git.kernel.org/stable/c/b942f88fe7d2d789e51c5c30a675fa1c126f5a6d
- https://git.kernel.org/stable/c/e95d97c9c8cd0c239b7b59c79be0f6a9dcf7905c
- https://git.kernel.org/stable/c/a406aff8c05115119127c962cbbbbd202e1973ef
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-22079 · CVE Program
- CVE-2025-22079 · NVD
- FIRST EPSS
- GHSA-h8h5-wj84-22hp · GitHub Advisory Database · CC BY 4.0
- CVE-2025-22079 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences