eth: bnxt: fix out-of-range access of vnic_info array
Priority LOW 31CWE-125Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: eth: bnxt: fix out-of-range access of vnic_info array The bnxt_queue_{start | stop}() access vnic_info as much as allocated, which indicates bp->nr_vnics. So, it should not reach bp->vnic_info[bp->nr_vnics].
Why it matters now
EPSS 0.00204 10th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 6.12.35, 6.14, 6.14.2 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.12.20 to before 6.12.35; 6.13.8 to before 6.14 | 6.12.35, 6.14 | Patch available | CNA |
| Linux | Linux | 6.14 and later | 6.12.35, 6.14.2, 6.15 | Patch available | CNA |
- Linux VendorLinux Affected 6.12.20 to before 6.12.35; 6.13.8 to before 6.14 Fixed in 6.12.35, 6.14 Patch available CNA
- Linux VendorLinux Affected 6.14 and later Fixed in 6.12.35, 6.14.2, 6.15 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.12.20 to before 6.12.35; 6.13.8 to before 6.14 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* | 6.14 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* | 6.14 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.14.1:*:*:*:*:*:*:* | 6.14.1 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.12.20 to before 6.12.35; 6.13.8 to before 6.14 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:-:*:*:*:*:*:* Versions 6.14 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14:rc7:*:*:*:*:*:* Versions 6.14 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.14.1:*:*:*:*:*:*:* Versions 6.14.1 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.12.35, 6.14
- Fix · CNA Linux (Linux) Fixed in 6.12.35, 6.14.2, 6.15
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22112
- 2026-10-03 Alias added: GHSA-mq3f-36rm-5qp5
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2025-22112 · CVE Program
- CVE-2025-22112 · NVD
- FIRST EPSS
- GHSA-mq3f-36rm-5qp5 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-22112 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences