Improper authentication on SAML SSO process allows user impersonation in sentry
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getsentry | sentry | 21.12.0 to before 25.1.0 | 25.1.0 | Patch available | CNA |
| — | sentry (PyPI) | 21.12.0 to before 25.1.0 | 25.1.0 | Patch available | GHSA-7pq6-v88g-wf3w |
- sentry Vendorgetsentry Affected 21.12.0 to before 25.1.0 Fixed in 25.1.0 Patch available CNA
- sentry (PyPI) Vendor— Affected 21.12.0 to before 25.1.0 Fixed in 25.1.0 Patch available GHSA-7pq6-v88g-wf3w
Remediation
- Fix · CNA sentry (getsentry) Fixed in 25.1.0
- Fix · GHSA-7pq6-v88g-wf3w sentry (PyPI) Fixed in 25.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22146
- 2026-10-03 Alias added: GHSA-7pq6-v88g-wf3w
References
More getsentry vulnerabilities
- TI-2026-21018 Sentry allows unauthorized access to event data across organizational boundaries CVSS 4.0MEDIUM 5.7
- TI-2026-30656 Sentry: Improper authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.8
- TI-2026-78982 Sentry-Javascript: Middleware Bypass when using Tunnel route CVSS 4.0CRITICAL 9.1
- TI-2023-25212 Sentry Next.js vulnerable to SSRF via Next.js SDK tunnel endpoint CVSS 3.1CRITICAL 9.3
- TI-2026-21634 Sentry: Improper Authentication on SAML SSO process allows user identity linking CVSS 3.1CRITICAL 9.1
- TI-2026-37904 Sentry: Inefficient Regular Expression Complexity in sentry CVSS 3.1HIGH 7.5
Sources
- CVE-2025-22146 · CVE Program
- CVE-2025-22146 · NVD
- FIRST EPSS
- GHSA-7pq6-v88g-wf3w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences