CVE-2025-22227: Authentication Leak On Redirect With Reactor Netty HTTP Client
Priority LOW 27CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
In some specific scenarios with chained redirects, Reactor Netty HTTP client leaks credentials. In order for this to happen, the HTTP client must have been explicitly configured to follow redirects.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00405 35th percentileScored 2026-11-07
Fix Partial Reactor Netty (VMware): 1.0.49 (Reactor BOM 2020.0.48), 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20), 1.2.8 (Reactor BOM 2024.0.8) +1io.projectreactor.netty:reactor-netty-http (Maven): 1.3.0-M5, 1.2.8Red Hat: 5 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Reactor Netty | 1.0.x to before 1.0.49 (Reactor BOM 2020.0.48); 1.1.x to before 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20); 1.2.x to before 1.2.8 (Reactor BOM 2024.0.8); 1.3.x to before 1.3.0-M5 (Reactor BOM 2025.0.0-M5) | 1.0.49 (Reactor BOM 2020.0.48), 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20), 1.2.8 (Reactor BOM 2024.0.8), 1.3.0-M5 (Reactor BOM 2025.0.0-M5) | Patch available | CNA |
| — | io.projectreactor.netty:reactor-netty-http (Maven) | 1.3.0-M1 to before 1.3.0-M5 | 1.3.0-M5 | Patch available | GHSA-4q2v-9p7v-3v22 |
| — | io.projectreactor.netty:reactor-netty-http (Maven) | before 1.2.8 | 1.2.8 | Patch available | GHSA-4q2v-9p7v-3v22 |
- Reactor Netty VendorVMware Affected 1.0.x to before 1.0.49 (Reactor BOM 2020.0.48); 1.1.x to before 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20); 1.2.x to before 1.2.8 (Reactor BOM 2024.0.8); 1.3.x to before 1.3.0-M5 (Reactor BOM 2025.0.0-M5) Fixed in 1.0.49 (Reactor BOM 2020.0.48), 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20), 1.2.8 (Reactor BOM 2024.0.8), 1.3.0-M5 (Reactor BOM 2025.0.0-M5) Patch available CNA
- io.projectreactor.netty:reactor-netty-http (Maven) Vendor— Affected 1.3.0-M1 to before 1.3.0-M5 Fixed in 1.3.0-M5 Patch available GHSA-4q2v-9p7v-3v22
- io.projectreactor.netty:reactor-netty-http (Maven) Vendor— Affected before 1.2.8 Fixed in 1.2.8 Patch available GHSA-4q2v-9p7v-3v22
Remediation
- Fix · CNA Reactor Netty (VMware) Fixed in 1.0.49 (Reactor BOM 2020.0.48), 1.1.32 (Reactor BOM 2022.0.27 and 2023.0.20), 1.2.8 (Reactor BOM 2024.0.8), 1.3.0-M5 (Reactor BOM 2025.0.0-M5)
- Fix · GHSA-4q2v-9p7v-3v22 io.projectreactor.netty:reactor-netty-http (Maven) Fixed in 1.3.0-M5 Advisory →
- Fix · GHSA-4q2v-9p7v-3v22 io.projectreactor.netty:reactor-netty-http (Maven) Fixed in 1.2.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 7 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform 8 | Affected | No fix yet: Fix deferred |
| Red Hat JBoss Enterprise Application Platform Expansion Pack | Affected | No fix yet: Fix deferred |
| Red Hat build of Apache Camel for Spring Boot 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22227
- 2026-10-03 Alias added: GHSA-4q2v-9p7v-3v22
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-22227 · CVE Program
- CVE-2025-22227 · NVD
- FIRST EPSS
- GHSA-4q2v-9p7v-3v22 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-22227 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences