Sensitive information in log files in iTerm2
Priority MEDIUM 47CWE-532Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-532.
Summary
iTerm2 3.5.6 through 3.5.10 before 3.5.11 sometimes allows remote attackers to obtain sensitive information from terminal commands by reading the /tmp/framer.txt file. This can occur for certain it2ssh and SSH Integration configurations, during remote logins to hosts that have a common Python installation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00494 42nd percentileScored 2026-11-07
Fix Fixed iTerm2 (iTerm2): 3.5.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA iTerm2 (iTerm2) Fixed in 3.5.11
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22275
- 2026-10-03 Alias added: GHSA-p83h-g6jw-gh8f
References
More Iterm2 vulnerabilities
- TI-2024-25648 An issue was discovered in iTerm2 3.5.x before 3.5.2. CVSS 3.1CRITICAL 9.8
- TI-2023-24916 iTerm2 before 3.4.20 allow (potentially remote) code execution because of mishandling of… CVSS 3.1CRITICAL 9.8
- TI-2023-24915 iTerm2 before 3.4.20 allow (potentially remote) code execution because of mishandling of… CVSS 3.1CRITICAL 9.8
- TI-2026-29861 In iTerm2 through 3.6.9, displaying a .txt file can cause code execution via DCS 2000p… CVSS 3.1HIGH 7.8
- TI-2024-25647 In iTerm2 before 3.5.2, the "Terminal may report window title" setting is not honored… CVSS 3.1CRITICAL 9.8
- TI-2022-22670 iTerm2 before 3.4.18 mishandles a DECRQSS response. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-22275 · CVE Program
- CVE-2025-22275 · NVD
- FIRST EPSS
- GHSA-p83h-g6jw-gh8f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences