WordPress Private Messages for UserPro plugin <= 4.10.0 - Local File Inclusion vulnerability
Priority LOW 36CWE-98Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-98.
Summary
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in DeluxeThemes Private Messages for UserPro userpro-messaging.This issue affects Private Messages for UserPro: from n/a through <= 4.10.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00559 46th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DeluxeThemes | Private Messages for UserPro | up to 4.10.0 | — | No fix listed | CNA |
- Private Messages for UserPro VendorDeluxeThemes Affected up to 4.10.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22311
- 2026-10-03 Alias added: GHSA-mh65-27wg-9p5h
More DeluxeThemes vulnerabilities
- TI-2019-10789 cosenary Instagram-PHP-API (aka Instagram PHP API V2), as used in the UserPro plugin… CVSS 3.0MEDIUM 6.1
- TI-2017-12173 The UserPro plugin before 4.9.17.1 for WordPress, when used on a site with the "admin"… CVSS 3.0CRITICAL 9.8
- TI-2023-02290 UserPro <= 5.1.1 - Authentication Bypass to Administrator CVSS 3.1CRITICAL 9.8
- TI-2024-11883 Media Manager for UserPro <= 3.12.0 - Missing Authorization to Unauthenticated Arbitrary Options Update CVSS 3.1CRITICAL 9.8
- TI-2023-02301 UserPro <= 5.1.1 - Insecure Password Reset Mechanism CVSS 3.1CRITICAL 9.8
- TI-2024-23569 WordPress UserPro plugin <= 5.1.8 - Unauthenticated Account Takeover vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-22311 · CVE Program
- CVE-2025-22311 · NVD
- FIRST EPSS
- GHSA-mh65-27wg-9p5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences